IBM RSA II adapter and Java RE 1

Today, after a short break (you can call it break, I think), I sat down and looked at the IBM RSA II adapter’s remote management GUI and it’s trouble with JRE versions. Ever since the last Java updates, I was unable to access the RSA console because Java would throw an error like this:

In the end, I downloaded every version since JRE 1.5.0.11 (that is 20 different versions :!:), as wittnessed by Michael Ellerbeck that the last working version for him was JRE 1.5.0.11, and gave each one a try (since I want to report the issue to IBM, so that they gonna release a fix sometime soon).

So here’s the list of what Java JRE version works with an RSA II adapter running Firmware 1.10 (GGEP36B):

  • Java JRE 1.50 U11 ……… works
  • Java JRE 1.50 U12 ……… works¹
  • Java JRE 1.50 U13 ……… works
  • Java JRE 1.50 U14 ……… works
  • Java JRE 1.50 U15 ……… works
  • Java JRE 1.50 U16 ……… works
  • Java JRE 1.50 U17 ……… works
  • Java JRE 1.50 U18 ……… works
  • Java JRE 1.60        ……… works
  • Java JRE 1.60 U01 ……… works
  • Java JRE 1.60 U02 ……… works
  • Java JRE 1.60 U03 ……… works
  • Java JRE 1.60 U04 ……… works
  • Java JRE 1.60 U05 ……… works
  • Java JRE 1.60 U06 ……… works
  • Java JRE 1.60 U07 ……… works
  • Java JRE 1.60 U12 ……… not working (see above)
  • Java JRE 1.60 U13 ……… not working (see above)
  • Java JRE 1.60 U14 ……… not working (see above)

1: This version presents some small annoyances (garbled video output)

Update: IBM already knows about the problem, but says it’s presumably a Java problem since it stopped working mid-version in between U11 and U12.

One comment on “IBM RSA II adapter and Java RE

  1. Pingback: IBM RSA II adapter and Java RE (fini) ← BAFM

Leave a Reply