WDS and DL580 G7

We recently received a shipment of Hewlett Packards all-new DL580 G7. While I’m impressed with what they did with the iLO3, I’m quite disappointed with what they did to the PXE-ROM.

Sure, gPXE may be the future and is offering more possibilites than “normal” PXE, however breaking customers deployment option(s) — at least for Windows that is — really wouldn’t be an option.

Now for the long story, we needed to install a temporary Windows on this DL580 (one with testing purposes). That said, we tried for three days to actually make this work (trying different things with the boot image), but it kept ending with the same result.

WDSClient: there was a problem initializing wds mode
WDSClient: there was a problem initializing wds mode

As you can see from the screenshot, the error message isn’t exactly clear as day. However, after pressing SHIFT + F10, working my way into X:WINDOWSPanther, digging around in the logs I saw a message that the WDS environment wasn’t getting information from the boot controller (like IP address and subnet mask, which is apparently passed on from the controller). So I opened a case with Hewlett-Packard, and guess what they said …

Exactly right, please open up a case with Microsoft, since this is a problem with WDS .. then again, I don’t have the luxury of opening a case with Microsoft since we don’t exactly have Microsoft support … 😛 So in the end, we installed them DL580’s with the addon NC362t network adapters, since that works.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.